ΤΑΣΕΙΣ

ΠΑΙΧΝΙΔΙΑ

ΥΛΙΚΟ

ΒΙΝΤΕΟ

29/5/13

Απαντήσεις Πανελλαδικών Εξετάσεων 2013 - Ανάπτυξη Εφαρμογών Σε Προγραμματιστικό Περιβάλλον Τεχνολογικής Κατεύθυνσης

ΠΡΟΤΕΙΝΟΜΕΝΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΤΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ
Α1.
1-Λ
2-Σ
3.-Σ
4-Λ
5-Σ
6-Λ

Α2.
Κß1
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 4
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
ΑΝ ΠΙΝ[ι,j]<>Ο ΤΟΤΕ
Α[Κ]ßi
Α[Κ+1]ßj
Α[Κ+2]ß ΠΙΝ[ι,j]
ΚßΚ+3
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Α3.
α) Σχολικό Βιβλίο σελ 19
β) Σχολικό Βιβλίο σελ 65
γ) Σχολικό Βιβλίο σελ 127

Α4.
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 99
ΓΙΑ j ΑΠΟ i+1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ Π[I,j]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Α5.
1-ε
2-ζ
3-στ
4-α
5-β
6-γ
7-δ

Β2.

Κß0
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 100
ΑΝ Π[Ι] =ΑΛΗΘΗΣ ΤΟΤΕ
ΚßΚ+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
Π[Ι]ß (Ι<=Κ)
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Γ.
!Γ.1
ΑΛΓΟΡΙΘΜΟΣ ΘΕΜΑΓ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
ΔΙΑΒΑΣΕ ΚΩΔ [Ι]
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 10
ΔΙΑΒΑΣΕ ΚΕΦ[Ι,J], ΑΚΡ[Ι,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


!Γ.2
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
ΑΘΡ1ß0
ΑΘΡ2ß0
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 10
ΑΘΡ1ßΑΘΡ1+ΚΕΦ[Ι,J]
ΑΘΡ2ßΑΘΡ2+ΑΚΡ[Ι,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ[Ι,1]ßΑΘΡ1/10
ΜΟ[Ι,2]ßΑΘΡ2/10
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Γ3
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
ΑΝ ΜΟ[Ι,1]<=1.8 ΤΟΤΕ
ΑΝ ΜΟ[Ι,2]<=3.6 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ “Χαμηλός SAR”
ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,2]<=4 ΤΟΤΕ
ΕΜΦΑΝΙΣΕ “Κοντά στα όρια”
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ “Εκτός ορίων”
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,1]<=2 ΤΟΤΕ
ΑΝ ΜΟ[Ι,2]<=4 ΤΟΤΕ

ΕΜΦΑΝΙΣΕ “Κοντά στα όρια”
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ “Εκτός ορίων”
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
ΕΜΦΑΝΙΣΕ “Εκτός ορίων”
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Γ4.
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 30
ΓΙΑ J ΑΠΟ 30 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
ΑΝ  ΜΟ[J-1,1]> ΜΟ[J,1] TOTE
TEMPß ΜΟ[J-1,1]
ΜΟ[J-1,1]ß ΜΟ[J,1]
ΜΟ[J,1]ßTEMP
TEMPß ΜΟ[J-1,2]
ΜΟ[J-1,2]ß ΜΟ[J,2]
ΜΟ[J,2]ßTEMP
TEMP2ßΚΩΔ[J-1]
ΚΩΔ[J-1]ß ΚΩΔ[J]
ΚΩΔ[J]ßTEMP2
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι],ΜΟ[Ι,1]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 30
ΓΙΑ J ΑΠΟ 30 ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
ΑΝ  ΜΟ[J-1,2]> ΜΟ[J,2] TOTE
TEMPß ΜΟ[J-1,2]
ΜΟ[J-1,2]ß ΜΟ[J,2]
ΜΟ[J,2]ßTEMP
TEMPß ΜΟ[J-1,1]
ΜΟ[J-1,1]ß ΜΟ[J,12]
ΜΟ[J,1]ßTEMP
TEMP2ßΚΩΔ[J-1]
ΚΩΔ[J-1]ß ΚΩΔ[J]
ΚΩΔ[J]ßTEMP2
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι],ΜΟ[Ι,2]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ ΘΕΜΑΓ

Δ
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:EL[5],ES[5],Ι, ΑΠΑΝΤΗΣΗ,ΘΕΣΗ
ΠΡΑΓΜΑΤΙΚΕΣ:ΠΟΣΟΣΤΟ
ΧΑΡΑΚΤΗΡΕΣ:ΕΠΙΛΟΓΗ,ΧΩΡΑ
ΑΡΧΗ
!Δ1.β
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
EL[I]ß0
ES[I]ß0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ2 & Δ3

ΓΡΑΨΕ ‘για Διακοπή της εισαγωγής πάτησε Δ ή δ’
ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
ΟΣΟ ΕΠΙΛΟΓΗ<>’Δ’ ΚΑΙ ΕΠΙΛΟΓΗ <>’δ’ ΕΠΑΝΑΛΑΒΕ
ΔΙΑΒΑΣΕ ΧΩΡΑ,ΑΠΑΝΤΗΣΗ
ΑΝ ΧΩΡΑ=’ΕL’ ΤΟΤΕ
ΕL[ΑΠΑΝΤΗΣΗ]ßEL[ΑΠΑΝΤΗΣΗ] +1
ΑΛΛΙΩΣ
ΕS[ΑΠΑΝΤΗΣΗ]ßES[ΑΠΑΝΤΗΣΗ] +1
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ‘για Διακοπή της εισαγωγής πάτησε Δ ή δ’
ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ4
ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(EL,ΠΟΣΟΣΤΟ,ΘΕΣΗ)
ΓΡΑΨΕ ‘ΕL’, ΘΕΣΗ, ΠΟΣΟΣΤΟ
ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(ES,ΠΟΣΟΣΤΟ,ΘΕΣΗ)
ΓΡΑΨΕ ‘ΕS’, ΘΕΣΗ, ΠΟΣΟΣΤΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΜΕΓ_ΠΟΣ(Χ,Π,Θ)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:Χ[5],Θ,Ι,ΜΑΧ,ΑΘΡ
ΠΡΑΓΜΑΤΙΚΕΣ:Π
ΑΡΧΗ
ΑΘΡßΧ[1]
ΜΑΧßΧ[1]
Θß1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5
ΑΘΡß ΑΘΡ+Χ[Ι]
ΑΝ ΜΑΧ<Χ[Ι] ΤΟΤΕ
ΜΑΧßΧ[Ι]
ΘßΙ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Πß(ΜΑΧ/ΑΘΡ)*100
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
ΟΡΟΣΗΜΟ ΠΕΙΡΑΙΑ
ΜΑΡΓΑΡΩΝΗΣ ΠΑΝΑΓΙΩΤΗΣ
ΜΠΑΞΕΒΑΝΙΔΗΣ ΓΡΗΓΟΡΗΣ

Δημοσίευση σχολίου

ΤΡΟΠΟΙ ΕΠΙΚΟΙΝΩΝΙΑΣ

ΑΡΧΕΙΟ ΑΝΑΡΤΗΣΕΩΝ

ΚΑΤΗΓΟΡΙΕΣ

ΕΠΙΣΚΕΠΤΕΣ

TRANSLATE THIS SITE

 
Copyright © 2021 ΗΛΕΚΤΡΟΝΙΚΗ ΔΙΔΑΣΚΑΛΙΑ
Powered byBlogger